Xen console

Vu Pham vu at sivell.com
Fri Oct 3 12:15:32 PDT 2008

Lonni J Friedman wrote:
> On Fri, Oct 3, 2008 at 10:22 AM, Vu Pham <vu at sivell.com> wrote:
>> Lonni J Friedman wrote:
>>> On Fri, Oct 3, 2008 at 9:55 AM, Vu Pham <vu at sivell.com> wrote:
>>>> When I run the command "xm create -c mydom" on the Xen host, the console
>>>> for
>>>> the domain mydom opens as expected.
>>>> On my workstation, when I run ssh -l root -X xen-host "xm create -c
>>>> mydom"
>>>> it fails and complains that "Error opening terminal: unknown".
>>>> I can use vnc, nx to the xen-host but I would like to know how to do it
>>>> with
>>>> ssh -X.
>>> export TERM=xterm
>> I set it in both the workstation and in the command that sends thru ssh -X
>> but it does not help.
> How or where are you setting TERM=xterm ?
> Are both ends Linux?
> Can you successfully run any other apps successfully over ssh (xterm, etc)?
> If you ssh to the remote end, then manually run the commands manually,
> does that make a difference?

I set it at both ends with "TERM=xterm;export TERM". I only have that 
problem thru ssh -X with that particular command "xm create -c mydom", 
which -c is to open the console of the xen guest.

Any other commands, like xterm, xclock, gnome-terminal, or virt-manager 
... all run fine with ssh -X, i.e., they all show up on my workstation 
as expected.


More information about the Linux-users mailing list